There was an issue discovered earlier today that prevents View Composer from working with vSphere 4.1.

Because of that VMware View Composer 2.0.x is not supported in a vSphere vCenter Server 4.1 managed environment as vSphere vCenter Server 4.1 requires a 64 bit operating system and VMware View Composer does not support 64 bit operating systems.
 
VMware View 4.0.x customers who use View Composer should not upgrade to vSphere vCenter Server 4.1 at this time. The upcoming VMware View 4.5 will be supported on VMware vSphere 4.1.
 
Check out this VMware KB article for more information.

VMware apologizes for any inconvenience this may have caused you. If you know how to spread the word to your friends and colleagues, please do so.